Barrel valve breakage ??

Discussion in 'Pit Buzz' started by Compresser, Jun 7, 2020.

Tags:
  1. Compresser

    Compresser New Member

    Joined:
    Feb 3, 2010
    Messages:
    20
    Likes Received:
    0
    I'm having an issue with the Barrel valve breaking off at the mount point. This is the second time.
    Enderle K style valve bolted to a Hilborn Shotgun hat.
    The first time I had had some tire shake and chalked it up to that. I bought another housing and transferred the internals to it.
    Made a couple of shake free runs and bam! another breaks on the burnout.
    I'm at a loss as to what is causing this.
    Car is real soft on the launch at 1.05 best ET is 6.60 207
    I run a soft line to both the hat and port distribution blocks. I have seen both soft lines as well as hard lines being used.
    I have talked to others with the same setup and no problems.

    Any ideas please?
     
    #1
  2. kosky racing

    kosky racing Comp Eliminator

    Joined:
    May 11, 2003
    Messages:
    764
    Likes Received:
    38
    Is the line from the pump in tension?
     
    #2
  3. Compresser

    Compresser New Member

    Joined:
    Feb 3, 2010
    Messages:
    20
    Likes Received:
    0
    Kosky racing. No there is some slack on all of the lines.
     
    #3
  4. Fuel Cars

    Fuel Cars AA/AM

    Joined:
    Aug 20, 2003
    Messages:
    306
    Likes Received:
    8
    Maybe posting a picture of the barrel valve mounted and where it's broken would help
     
    #4

Share This Page